175 lines
4.1 KiB
Bash
175 lines
4.1 KiB
Bash
# Maintainer : Daniel Bermond <dbermond@archlinux.org>
|
|
# Contributor: Kamran Mackey <kamranm1200@gmail.com>
|
|
# Contributor: richteer <richteer at lastprime.net>
|
|
# Contributor: DrZaius <lou at fakeoutdoorsman.com>
|
|
|
|
pkgname=ffmpeg-git
|
|
pkgver=5.1.r106894.g260d7d5a6c
|
|
pkgrel=1
|
|
pkgdesc='Complete solution to record, convert and stream audio and video (git version)'
|
|
arch=('x86_64')
|
|
url='https://www.ffmpeg.org/'
|
|
license=('GPL3')
|
|
depends=(
|
|
aribb24
|
|
alsa-lib
|
|
aom
|
|
bzip2
|
|
fontconfig
|
|
fribidi
|
|
gmp
|
|
gnutls
|
|
gsm
|
|
jack
|
|
lame
|
|
libass.so
|
|
libavc1394
|
|
libbluray.so
|
|
libdav1d.so
|
|
libdrm
|
|
libfreetype.so
|
|
libiec61883
|
|
libmfx
|
|
libmodplug
|
|
libpulse
|
|
librav1e.so
|
|
libraw1394
|
|
librsvg-2.so
|
|
libsoxr
|
|
libssh
|
|
libtheora
|
|
libva.so
|
|
libva-drm.so
|
|
libva-x11.so
|
|
libvdpau
|
|
libvidstab.so
|
|
libvorbisenc.so
|
|
libvorbis.so
|
|
libvpx.so
|
|
libwebp
|
|
libx11
|
|
libx264.so
|
|
libx265.so
|
|
libxcb
|
|
libxext
|
|
libxml2
|
|
libxv
|
|
libxvidcore.so
|
|
libzimg.so
|
|
opencore-amr
|
|
openjpeg2
|
|
opus
|
|
sdl2
|
|
speex
|
|
srt
|
|
svt-av1
|
|
v4l-utils
|
|
vmaf
|
|
xz
|
|
zlib
|
|
)
|
|
makedepends=(
|
|
amf-headers
|
|
avisynthplus
|
|
clang
|
|
ffnvcodec-headers
|
|
git
|
|
ladspa
|
|
nasm
|
|
)
|
|
optdepends=('avisynthplus: for AviSynthPlus support'
|
|
'intel-media-sdk: for Intel Quick Sync Video'
|
|
'ladspa: for LADSPA filters'
|
|
'nvidia-utils: for Nvidia NVDEC/NVENC support')
|
|
provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
|
|
'libavutil.so' 'libpostproc.so' 'libswresample.so' 'libswscale.so'
|
|
'ffmpeg')
|
|
conflicts=('ffmpeg')
|
|
source=('git+https://git.ffmpeg.org/ffmpeg.git'
|
|
'040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch'
|
|
'060-ffmpeg-fix-segfault-with-avisynthplus.patch')
|
|
sha256sums=('SKIP'
|
|
'2df82046908015bf26bc1303275cf52ba01fa380029a54ea6415373e389e423c'
|
|
'0d6b53940a81ebaf4e6b1a2208a178eb8a824d6a3d8e863bf9c4c7e0060d88ec')
|
|
|
|
prepare() {
|
|
patch -d ffmpeg -Np1 -i "${srcdir}/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch"
|
|
patch -d ffmpeg -Np1 -i "${srcdir}/060-ffmpeg-fix-segfault-with-avisynthplus.patch"
|
|
}
|
|
|
|
pkgver() {
|
|
printf '%s.r%s.g%s' "$(git -C ffmpeg describe --tags --long | awk -F'-' '{ sub(/^n/, "", $1); print $1 }')" \
|
|
"$(git -C ffmpeg describe --tags --match 'N' | awk -F'-' '{ print $2 }')" \
|
|
"$(git -C ffmpeg rev-parse --short HEAD)"
|
|
}
|
|
|
|
build() {
|
|
cd ffmpeg
|
|
printf '%s\n' ' -> Running ffmpeg configure script...'
|
|
|
|
./configure \
|
|
--prefix='/usr' \
|
|
--disable-debug \
|
|
--disable-static \
|
|
--disable-stripping \
|
|
--enable-amf \
|
|
--enable-avisynth \
|
|
--enable-cuda-llvm \
|
|
--enable-lto \
|
|
--enable-fontconfig \
|
|
--enable-gmp \
|
|
--enable-gnutls \
|
|
--enable-gpl \
|
|
--enable-ladspa \
|
|
--enable-libaribb24 \
|
|
--enable-libaom \
|
|
--enable-libass \
|
|
--enable-libbluray \
|
|
--enable-libdav1d \
|
|
--enable-libdrm \
|
|
--enable-libfreetype \
|
|
--enable-libfribidi \
|
|
--enable-libgsm \
|
|
--enable-libiec61883 \
|
|
--enable-libjack \
|
|
--enable-libmfx \
|
|
--enable-libmodplug \
|
|
--enable-libmp3lame \
|
|
--enable-libopencore_amrnb \
|
|
--enable-libopencore_amrwb \
|
|
--enable-libopenjpeg \
|
|
--enable-libopus \
|
|
--enable-libpulse \
|
|
--enable-librav1e \
|
|
--enable-librsvg \
|
|
--enable-libsoxr \
|
|
--enable-libspeex \
|
|
--enable-libsrt \
|
|
--enable-libssh \
|
|
--enable-libsvtav1 \
|
|
--enable-libtheora \
|
|
--enable-libv4l2 \
|
|
--enable-libvidstab \
|
|
--enable-libvmaf \
|
|
--enable-libvorbis \
|
|
--enable-libvpx \
|
|
--enable-libwebp \
|
|
--enable-libx264 \
|
|
--enable-libx265 \
|
|
--enable-libxcb \
|
|
--enable-libxml2 \
|
|
--enable-libxvid \
|
|
--enable-libzimg \
|
|
--enable-nvdec \
|
|
--enable-nvenc \
|
|
--enable-shared \
|
|
--enable-version3
|
|
make
|
|
make tools/qt-faststart
|
|
}
|
|
|
|
package() {
|
|
make -C ffmpeg DESTDIR="$pkgdir" install
|
|
install -D -m755 ffmpeg/tools/qt-faststart -t "${pkgdir}/usr/bin"
|
|
}
|